I've got a Windows Core Server which was shut off for awhile. Unfortunately it appears to have lost the domain connection while off. Normally on a GUI Server or Workstation it's not a big deal, I would simply switch it to a workgroup, then switch back to the domain.

However, this Core install refuses to leave the domain to switch to a work group. I've tried the text menu tool. I've tried netdom from the cmd prompt. I've even tried the powershell commands. All of the above have been attempted with local admin as well as domain admin creds. "No mapping between account names and security IDs was done" is the error I get back from most of the tools.

What's special about Windows Core that it can't do this the way the GUI Windows would, and how do I work around/fix it?


TBH and IMHO, if you're disjoining the machine and rejoining it you're doing it the hard way and the wrong way. You can use Powershell or Netdom to reset the machine account password and resolve the issue without the disjoin/rejoin.



  • Both of those sound like the correct things to do, but neither works. PS returns a message about "Cannot get domain information..." and netdom returns "...No mapping between account names and security IDs..." despite me being able to see it in AD. :-( – Brian Knoblauch Oct 1 '18 at 13:10
  • I had to manually deleted the object and then manually re-created it in the domain before the above would work. It also took overnight to complete the sync (it re-appeared in all DCs after just 15 minutes, but I could not login until hours later). – Brian Knoblauch Oct 2 '18 at 13:33

Nothing special about core and domains other than making it harder to see.

  1. You can force a remove with Powershell: remove-computer -credential (get-credential) -force -WorkgroupName "Workgroup" (when prompted, enter the local rather than domain admin rights) and re-add with Add-Computer -DomainName "domain.com" -Server "dc1.domain.com" -Passthru -Verbose -credential (get-credential) (use a domain account with join rights)

The special sauce with the powershell command is the -force parameter which tells powershell "I don't give a damn if you can't find the DC, REMOVE ME!"

  1. You can cheat-use the gui with sysdm.cpl

  2. You can switch the system back from core to GUI to see the options if you need:

    Get-WindowsFeature -Name *gui* | Install-WindowsFeature -Restart

    And return to core afterwards

    Get-WindowsFeature -Name *gui* | Remove-WindowsFeature -Restart

If everything fails, I'd recommend disconnecting the NIC from the system and repeat what you've previously tried.

  • the third step is going to work if (Brian Knoblauch) has Windows Server 2012 R2 or any downlevel OS but won't work if it is Windows Server 2016. Just wanted to mention. – Humberto Castellon Sep 28 '18 at 20:01
  • @HumbertoCastellon Are you confusing Server Core and Nano? Or are you referring to the extra steps involved? 4sysops.com/archives/… – duct_tape_coder Sep 28 '18 at 20:14
  • No, I just wanted to say/add that Core-GUI conversion is not supported in Windows Server 2016 anymore, in case of the third step you mention in your answer. – Humberto Castellon Sep 28 '18 at 20:29
  • @HumbertoCastellon Did this change somewhere in the 2016 lifecycle? The article I linked shows how to do it. – duct_tape_coder Sep 28 '18 at 20:44
  • I've read it on Windows Server 2016 Microsoft books. I'd like to attach a screen capture of the book I'm talking about. Just in case you have it, the book title is Installation, storage and compute with Windows Server 2016. To stay on the safe side, maybe the conversion was a flexible way for admins and they brought it back. – Humberto Castellon Sep 28 '18 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.