Parse server version: 2.8.4

Parse dashboard version: 1.2.0

MongoDB version: 4.0.2

Hosting service: DigitalOcean

=======================================

I'm transferring my app to a new Parse server and a new MongoDB server. Everything works fine except the fact that I can't load any images! The content is being fetched properly, but the images don't load. Neither from the app, nor from the dashboard. (I get the File not found. there)

Here's how I transferred my db:

mongodump --host sourceIP -d dbName --port 27017

and then to load it:

mongorestore --db dbName dbDir --username “username” —password "password" --authenticationDatabase "admin"

I did a db.fs.files.find() and the images seem to be there just fine!

I also tried uploading a new image file and got the error: error 130. Could not store file.

I believe that this is a db-side issue, because I tested the parse server with another MongoDB I have and it was working!

I also tried creating a new droplet and redo everything, but it didn't fix it!

Any suggestions?

I spent 2.5 days of my life for the same issue, full of stress, just because I had the symbol & in my auth password, inside my databaseURI! For some reason, it doesn't affect fetching the data but it does affect fetching images!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.