I'm by NO means an IIS expert and I know very little about networking, but somehow fixing this error has fallen to me. for whatever reason (long story) our webserver was modified somehow (not by me) so that the identity of the application pool underwhich our websites run is not authenticating.

When browsing to a site, we are prompted for a username and password. no matter what we put in (even master admin account) we get a 401.1 invalid credentials error. If we cancel the prompt, then we get a 401.3 error. I tried setting the permissions on the folders for the site, enabling first read to network service (which is what is should be set at right?), then write, then full permissions to EVERYONE, still nothing. I undid that and tried about a 1000 different things...

finally I went into the applciation pool identity and changed it to Local System. I KNOW that I'm not supposed to do this, but changing this made everything work. I didn't even have to set permissions...

So now the site works but we have it running as local system instead of network service. I tried setting the permissions but no matter what I try it gives me the username password prompt...

I'm not sure what more information I can give; like i said I don't really know what i'm doing but for some reason this problem is mine. My only solution is to leave it as local system, then try to get our new webserver up and running several weeks/months ahead of schedule (iis 7, which I at least know a LITTLE more how to use) and copy everything over to that...

but why wouldn't the network service identity work even after setting full permissions to the everyone account?

the only thing I can think of is that when they reconfigured the webserver, they changed either the computer name or domain or something on which it was attached so that the account it's signing on with doesn't exist. but that probably doesn't make any sense...

any input would be greatly appreciated!

  • I also attempted creating a new application pool but that gives the same results... – Anonymous Dec 11 '09 at 9:35

More information is needed. How is the authentication to the site done? Is it anonymous ( and if so, what is the user the actual authentication is done with? This is not like the application pool identity.

Anyway, for now, you should check, in the "local security policy" tool, what are the permissions of the network service account. Look at the "Local policy"=>"user rights assignment". Specially at the "Replace a process level token".

|improve this answer|||||

You could be running into a permissions issue on some of the other files/folders that are involved. Network Service and Local System have to have access to more than just the folder containing your web app. See this KB article: http://support.microsoft.com/kb/842493

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy