I have a Windows 2016 Server configured as a Remote Desktop Gateway Server. Users will log into the server and use Word, Excel, ect…. These programs, as well as the "Devices and Printers" app in the Control Panel, will all hang at startup unless the print spooler on the server is NOT running. Printers are deployed to all domain user profiles via group policy in the "Printer Management" app for the domain. Typically the users will not need to print if they are logged in remotely so disabling the print spooler is not a huge issue. However, having the option to print would be desirable and people may find it necessary to print via redirected printers to a local printer attached to their local computers. Is there a way to have the printer spooler enabled and have the Office Products continue to work?

  • Hi, can you validate if the spooler process take a huge amount of CPU when the user session connect ? Often with users with more than 2-3 printers it can take a load of ressource to map all the printer. I often activate the option to map only the client default printer as a workaround, and install all print driver from the printserver in advance to prevent the spooler usage is remote desktop easy print is not activated – yagmoth555 Oct 4 '18 at 14:50
  • The cpu usage does spike when trying to access the devices and printers app which never does open. So, it is impossible to add/map the printers in advance. – Mark Oct 4 '18 at 14:58
  • You do use RDWeb and RDS on the same machine right? Triplecheck your printer drivers (and the print service evt). – bjoster Oct 8 '18 at 13:01
  • Yes, this is a RDP gateway server that users are logging into. Yes, RDWeb is on the same machine. What needs to be checked on the printer drivers? They are loaded via Group policy and work for all the of Windows 10 client computers on the LAN. – Mark Oct 8 '18 at 16:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.