After working with Windows Server since NT 3.51, this was kind of a first for me. Here's the scenario:

  • After no issues accessing a Windows Server 2012 R2 network share for 2 years, a Win 7 Pro workstation all of a sudden can access the mapped drive to the share, but cannot see all subfolders underneath it. Only one is visible, not the other 20 or so.
  • When I log out as the user and login as the domain admin account, the issue persists on the workstation. Just this one workstation.
  • Nothing has changed in terms of the share or NTFS permissions on the server-side of things.
  • I look in the server event logs as well as the workstation's and don't see anything striking.
  • I removed the workstation from the domain and add it again. The issue still persists.
  • The workaround is that I created a second share to the same resource on the server-side of things. Mapping a different drive letter to this new share, the workstation can see everything again. So I figure it isn't NTFS permissions. And on both shares the Everyone group has Read and Change rights.

My only guess would be some sort of old school SAM database corruption or something? I recall years ago I had a Windows 2000 Server that would lose Computer Browser functionality due to some odd SAM database corruption. The only solution back then was to reboot the server. It was the PDC and couldn't even browse its own network shares.

I ran the Powershell commands listed here on the server, and no integrity issues were found --> http://www.rebeladmin.com/2018/03/integrity-check-detect-low-level-active-directory-database-corruption/.

Any suggestions?

  • What happens if you map this new share to the old drive letter on this workstation? If this a plain old share or some kind of DFS? From your description it looks like your problem is linked to the software on this workstation, as removing/joining a domain should have created new computer account and SAM problems should not be inherited from the old one. – Peter Zhabin Oct 11 '18 at 12:18
  • 2
    Are you actually browsing the drive/share online? Or are you just hitting the offline files on the workstation? – Semicolon Oct 11 '18 at 15:30
  • It's just standard file sharing, not anything like DFS or offline files involved. I'll try drive mapping the old drive letter to the new file share I created. And see if that makes any difference. I tried browsing the old share using the UNC path at a cmd prompt and the issue was the same. Only one subfolder out of 20 appeared. Like I said, it's a pretty oddball phenomenon. Best case is that it's just a glitch on the specific workstation. Not nothing like deteriorating AD or SAM problems that will grow worse over time! – gregarican Oct 11 '18 at 20:11

Fixed it. I went through two steps -- 1) disabled Offline Files, although I didn't see any locally cached contents, and 2) disabled IPv6 (which we don't use). After rebooting the workstation I went back to this mapped drive and all contents were available again.

Frankly, since the Offline Files directory was empty I think it might have had something to do with something oddball with IPv6? Not sure how that would come into play, but at any rate the issue has been resolved.

That was certainly a first for me in terms of this scenario!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.