0

We have just installed a new mailserver, with exchange 2016. We need to have our wildcard certificate assigned with the smtp service in exchange. I edit the certificate in exhange EAC, tick the checkbox for "SMTP", but when I go and edit again, the SMTP checkbox is unticked. On our old mailserver the smtp-service is active on the certificate. Have also tried setting it trhough EMS.

We're currently running them both, but have migrated all mailboxes to the new one, and changed the dns to point to the new.

I suspect it's this that gives us a certificate warning when starting outlook. The warning says that the certificate (our wildcard cert) is OK, but it doesn't match the place, and the name it gives us as a title for the warning is servername.ourdomain.local, and not the true address mail.our.domain as the certificate is covering.

Anyone got any idea how to solve this?
We have yet to do a restart of the server, but we will try that as soon as we can. Just asking if there's anything else to try that we haven't found or thought of.

Regards Stoffe Eriksson Sysadmin, Västgöta-data AB

  • You should post results of Get-ExchangeCertificate | fl and Get-MapiVirtualDirectory | fl with some of the more sensitive info redacted. Also, post the actual commands in EMS that you ran. – Joseph Oct 25 '18 at 10:55
0

As per my experience, if you assign the new cert to SMTP service, you will get a warning that "overwrite the exist SMTP certificate?", if you click yes, then the current SMTP cert will be replaced.

You could run the "Get-ExchangeCertificate | fl Subject,Services" to check the cert services.

If the warning did get passed but issue persists, you may remove SMTP service from the old cert and then re-enable the new cert.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.