I have a running WEB server with Ubuntu 14.04.5 LTS with LAMP environment. The server is running in a Vagrant/VirtualBox virtual machine.

I made a release upgrade to Ubuntu 16. The upgrade had no error, but after I restarted the guest system I could not log in through ssh into the guest. it did not give me login prompt on the gui. The last messages can be seen here:

enter image description here

The appropriate VirtualBox process is using 100% CPU on the host.

I don't see any error in the VirtualBox log. It is absolutely the same as th log of successful booting with Ubuntu 14. But the log ends with the following lines:

00:00:03.373112 PIT: mode=2 count=0x10000 (65536) - 18.20 Hz (ch=0)
00:00:03.373373 VMMDev: Guest Log: BIOS: Boot : bseqnr=1, bootseq=0002
00:00:03.373822 VMMDev: Guest Log: BIOS: Booting from Hard Disk...
00:00:04.464068 PIT: mode=2 count=0x12a5 (4773) - 249.98 Hz (ch=0)
00:00:04.740030 PIT: mode=0 count=0x10000 (65536) - 18.20 Hz (ch=0)
00:00:04.746800 CPUM: VCPU  1: Cached APIC base MSR = 0xfee00800
00:00:06.067801 AHCI#0: Reset the HBA
00:00:06.094234 AHCI#0: Port 0 reset
00:00:08.520691 NAT: Link up

while the old (successful one) continues:

00:00:04.310395 PIT: mode=2 count=0x12a5 (4773) - 249.98 Hz (ch=0)
00:00:04.670117 PIT: mode=0 count=0x10000 (65536) - 18.20 Hz (ch=0)
00:00:04.675933 CPUM: VCPU  1: Cached APIC base MSR = 0xfee00800
00:00:06.058491 AHCI#0: Reset the HBA
00:00:06.067719 AHCI#0: Port 0 reset
00:00:08.049147 NAT: Link up
00:00:10.181385 VMMDev: Guest Additions information report: Version 4.3.36 r105129 '4.3.36_Ubuntu'
00:00:10.181441 VMMDev: Guest Additions information report: Interface = 0x00010004 osType = 0x00053100 (Linux >= 2.6, 64-bit)
00:00:10.181529 VMMDev: Guest Additions capability report: (0x0 -> 0x0) seamless: no, hostWindowMapping: no, graphics: no

May be, that something with the guest addition?

up vote 1 down vote accepted

This has been discussed at length a while back at AskUbuntu. In short, it tries to initialize a non-existent serial console and fails miserably. You should either attach virtual serial port with VirtualBox or remove console=ttyS0 from Grub boot menu options.

  • Enabling and configuring COM1 az raw file in VirtualBox manager solved the problem. Thanks. – Tibor Nagy Oct 12 at 15:06
  • The final solution was the removing of console=ttyS0 from /etc/default/grub.d/50-cloudimg-settings.cfg and running update-grub. – Tibor Nagy Oct 15 at 12:27

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.