-3

Till Friday 12/10/2018 I was able to run sudo commands (Ex:sudo mongodump --db iot_ac). Today When I tried to run any command as root(sudo),i get the below message(Connected through SSH):

We trust you have received the usual lecture from the local System Administrator. It usually boils down to these three things:

  1. Respect the privacy of others.

  2. Think before you type.

  3. With great power comes great responsibility.

[sudo] password for platformcloudtest:

Also not sure where I can find the password also, Please Help.

  • What are you doing differently? – Michael Hampton Oct 15 '18 at 12:28
  • I have been doing the same thing ,is there a way to get the password of the instance ([sudo] password for platformcloudtest) – Prem Sanil Oct 15 '18 at 12:35
  • The password is whatever you set it to. – Michael Hampton Oct 15 '18 at 12:40
  • I have not set any password !,Is there any other way to get out of this issue .. – Prem Sanil Oct 15 '18 at 14:44
  • 1
    @PremSanil: Do not flag again, there is nothing here that needs mod intervention. Don't abuse flags to have things you don't want to hear or you don't deem helpful deleted. – Sven Oct 16 '18 at 17:45
-1

It seems that a change (maybe an update) happened and user is longer part of the “Google-sudoers” group

This workaround helped me to solve the issue :

1.Adde a new user in IAM & admin page with Role Compute Admin , Owner

2.Once logged in just changed the the username from the Terminal Options->Change Linux Username

3.Enter the command sudo -i

4.run sudo commands without any issues.

find more information: Please visit the issue-tracker thread of Google Cloud Platform

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.