0

I have postfix and a local LMTP server running. In my main.cf, I have append_at_myorigin = no. When I run postconf|grep append_at_myorigin I get that this value is no.

But for some reason, postfix is still appending myorigin to non-FQDNs (i.e. sending to user becomes user@my-devices-hostname), and unsurprisingly the LMTP server has no idea what to do with these rewritten addresses.

Why is postfix doing this, and how can I make it stop?

0

According to: http://www.postfix.org/postconf.5.html, append_at_myorigin should not be changed. Without seeing your logfiles, it's a bit hard to understand what's going on. Try setting verbose logging for the snmpd in master.conf " snmpd -v

smtp      inet  n       -       n       -       -       smtpd

the man page

append_at_myorigin (default: yes)
With locally submitted mail, append the string "@$myorigin" to mail addresses without domain information. With remotely submitted mail, append the string "@$remote_header_rewrite_domain" instead.

Note 1: this feature is enabled by default and must not be turned off. Postfix does not support domain-less addresses.

Note 2: with Postfix version 2.2, message header address rewriting happens only when one of the following conditions is true:

The message is received with the Postfix sendmail(1) command,
The message is received from a network client that matches $local_header_rewrite_clients,
The message is received from the network, and the remote_header_rewrite_domain parameter specifies a non-empty value.
To get the behavior before Postfix version 2.2, specify "local_header_rewrite_clients = static:all".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.