0

Whenever any of our SVN users try to commit to the repository after the server has been idle for a while (e.g., first commit of the day), the Commit dialog hangs for precisely one minute, regardless of the size of the commit. When the commit finishes, the status message displays something like “5 kBytes transferred in 1 minute(s) and 0 second(s)”. Subsequent commits proceed without any delay. I read on another forum a suggestion that it might have to do with LDAP caching, but I don’t know how one might investigate that. Can you explain what might be causing this?

UPDATE: I am using SVN on a locally owned server, installed by SubversionEdge from CollabNet (v5.2.2), along with TortoiseSVN 1.10. The backend is ActiveDirectory (maintained on a separate corporate server). The LDAP is configured through SubversionEdge. I have access to the settings page, but they are all greek to me (I don't have any LDAP expertise).

UDPATE #2: I suspect this problem may be related to the one described by Gerald, here. However, that one was resolved by adjusting LDAPConnectionPoolTTL, but that setting is not available on the Authentications page for my SVN/LDAP settings, so I do not know how to adjust it.

  • 1
    More information about the server setup would be helpful. What kind of SVN server? How is the authentication configured? What is the backend, ActiveDirectory, a different LDAP? – Gerald Schneider Oct 16 '18 at 16:26
  • 1
    A shot in the dark, but the 1 minute delay reminds me of this problem I had. – Gerald Schneider Oct 16 '18 at 16:27
  • @GeraldSchneider: I have updated my question, but not sure I've given you the details you need. Your other post is very interesting; I have posted a follow up question there – kmote Oct 16 '18 at 16:39
  • your comment there is not very useful, as it's not related to that question. You should discuss your problem only here. I'm afraid I'm not familiar with SubversionEdge, maybe someone else can shed some light on this. But I suspect a similar problem as I had. I added the relevant tags so It can be found more easily. – Gerald Schneider Oct 16 '18 at 17:07
  • Thank you for your help, @GeraldSchneider. I have removed the question from the other page. – kmote Oct 16 '18 at 17:31
1

Thanks to GeraldSchneider's detailed description of a similar issue I was able to identify that the problem had to do with an LDAP authentication setting known as LDAPConnectionPoolTTL. The challenge was to find out how to adjust that setting within the CollabNet administration portal. It is not on the Authentication page. Rather, you must navigate to "Server Settings", then click the "Advanced Settings" link, and at the bottom of that page there are these two fields:

Connection Pool TTL (default: -1 -- attempt to reuse connections indefinitely)

and,

Timeout (default: 60 seconds; this corresponds to the LDAP response time)

I am not exactly sure what the optimal settings for those fields are. I have found numerous suggestions on various forums:

Personally, I have decided to experiment with a setting of 899 for the Pool TTL and reducing the LDAP response timeout to 10.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.