0

After screwing up in Debian Jessie (accidentally run rm -R /) my server stopped responding and I decided to reboot. After rebooting grub rescue started and tried to fix it by running the following commands:

set root=(hd0,1)
set prefix=(hd0,1)/usr/lib/grub
insmod normal
normal

No errors so far, after running "normal" grub2 promps up. So I'm not sure what to do here because I don't want to lose my files.

In grub2 if I run ls (hd0,1)/ I recognize my server and files. What are the following steps to boot debian as normal again?

  • Some of your files will be there. You may not have enough left to actually boot the system. You probably will need to reinstall. – Michael Hampton Oct 16 '18 at 19:53
0
  1. confirm that everything in /etc/grub.d and /etc/default/grub is correct
  2. run update-grub2 to recreate /boot/grub/grub.cfg
  3. grub-install /dev/sda (or other as appropriate)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.