0

We are experiencing a strange problem with our 2012R2 DHCP server. Setup looks like this: Superscope with two scopes:
SCOPE 1 - 192.168.100.0/24 (for PC)
SCOPE 2 - 192.168.101.0/24 (for IP phones)

No vlans or anything, just fortigate router with internal interface configured with secondary IP address. All devices can communicate between theese subnets. When any device (Windows, Linux, IP phone etc.) is connected to network, it gets lease from DHCP server without problem (from SCOPE 1 which is first in a list - as expected).

We wanted to setup reservations in scope 2 so each phone connected gets it's address in 192.168.101.0 subnet. When we tried this phones were just trying to obtain lease endlessly.

We then tried to reserve some Windows or Linux PC's to scope 2 and they were getting this reservations without problem. If we reserve IP phone to SCOPE 1 everything is fine.

No policies are configured for DHCP server. All settings are default. Both scopes configured for offering DHCP. I've also tried to configure bootp for SCOPE 2 but this has no effect.

I've tried to inspect what's happening on DHCP server with wireshark and it's goes like this:

  1. Client Discover
  2. DHCP Offer (offers reserved IP)
  3. Client Request (requests reserved IP)
  4. DHCP NAK

What could cause this and how do I battle it?

  • Just for testing purposes I spoofed MAC of a PC with a MAC from IP phone (I disconnected it so no collisions or anything). And perfectly fine PC is getting DHCP NAK now. So now it seems that DHCP is corrupted somehow, because I can't find where are these abandoned MAC of phones are defined. Nothing in gui, nothing in Get-DhcpServerv4Reservation. What can I do in this situation, besides deleting DHCP server and installing it again? – Andrew S. Oct 18 '18 at 7:18
0

AFAIK, the DHCP server will not assign ip addressing from the second scope in your superscope until the first scope is exhausted, reservations or not.

  • This is true only for non-rserved IP. – Andrew S. Oct 19 '18 at 6:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.