0

I have a Cisco SG300 managed switch I am attempting to configure to handle two VLANs one for data (VLAN1) and another for voice (VLAN20).

Ports 1 and 52 are configured to trunk to the router/firewall, and to a second SG300 switch, respectively.

The remaining ports 2-48 on both switches are set to access mode with access allowing for VLAN20.

However, default VLAN1 traffic is not passing through the port. How can I allow for both VLAN1 and VLAN20 traffic to be used by the remaining ports? Each of the remaining ports will have Cisco and Polycom phones daisy-chained to a PC. The PCs will have no tagged VLANs, phones will have VLAN20.

vlan database
vlan 20
exit
voice vlan id 20
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
hostname HHSSW02
username Admin password encrypted 69a3ff8b0f977aab794acfdd3bbf5fae926b6c2f privilege 15
power inline traps enable
ip ssh server
snmp-server community access1grapher ro view Default
snmp-server host 192.168.1.254 traps version 2c access1grapher
clock timezone CST -6
clock source sntp
sntp unicast client enable
sntp unicast client poll
sntp server time-a.timefreq.bldrdoc.gov poll
ip telnet server
!
interface vlan 1
 ip address 192.168.100.5 255.255.255.0
 no ip address dhcp
!
interface gigabitethernet1
 description FIREWALL
 switchport trunk allowed vlan add 20
 power inline priority high
!
interface gigabitethernet2
 switchport mode access vlan 20
 power inline priority high
!
0

You don't have VLAN 1 allowed on interface 1.

And you have VLAN 20 specified on interface 2. You need to specify VLAN 1, and specify voice vlan enable

  • When I attempt to apply VLAN1 to any interface, it removed VLAN20 and does not show VLAN 1 in the config. Would this be because it is the default VLAN? – Kevin Oct 19 '18 at 16:43
  • Also, I get "access mode prevents executing voice enable... – Kevin Oct 19 '18 at 17:12
  • I switched it to general mode and it lets me apply the command, but how does general mode differ in this case from access? – Kevin Oct 19 '18 at 17:44
  • I'm not entirely familiar with the SG line. From my reading, it appears that switchport mode general sets the native vlan to 1, and then switchport general allowed vlan add 20 tagged allows the phones to communicate on VLAN 20. This is just a guess, though. – longneck Oct 19 '18 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.