1

We had a Windows Server 2012 AWS Instance on EC2 that worked just fine, had a VPN connection to our office and we could RDP into it from our office.

However, I was in the process of trying to unblock the internet from inside the instance, and, in doing so, I followed some help articles from Amazon with what the default ACL and security group settings should look like. (port 80 and so on)

Did all of that, and, lo and behold, the next day, I completely lost access to the instance.

I've tried absolutely everything to regain access to it, even opened all traffic on both the one ACL and Security group we have both ways, and I still can't RDP into it anymore. At one point I noticed that something seemed to take effect in reverse, it was like, if I explicitly added an RDP rule or something, it would the adverse effect of blocking it but when I'd remove it it would be fine? (I don't remember exactly what the rule was unfortunately)

In any case, the fact that I'm even trying to allow all traffic in both directions on both layers of security and it still not working is just confusing.

I can't try any of the automated troubleshooting tools as unfortunately it wasn't set up as a managed instance to begin with, so I'm a bit screwed. I even tried EC2Rescue and even that fails...

Worse off, I even restored to a snapshot taken before any changes were made inside the instance and we now can't connect to even that...

All I did in the instance was try to disable the Windows Firewall, but I could still access it for some time after that, so, I don't know what actually cut access to it.

Unfortunately we don't have any support with Amazon and no one ever answers on their support forum...

I double and triple-checked everything, the routing table, the igw, the subnet, that the ACL and security group are assigned to the instance, went through multiple reboots, everything, but I still can't connect to it.

I can see the instance being just fine through the screenshot, but otherwise, we've completely lost connectivity to it.

Any help would be greatly appreciated as I'm just stumped.

Thanks.

Here are some screenshots:

ACL

Security group inbound

Security group outbound

  • AWS developer support is fairly cheap, get that for a month. If a snapshot from before this problem happened is also not working it's most likely the problem is with your AWS settings. You haven't given us enough information to help diagnose that, and in practice it'd be better to have someone have a look directly rather than paste in a bunch of screenshots. Do you have anyone who can do a review, either a peer or a consultant? – Tim Oct 25 '18 at 18:34
  • Hi there. Unfortunately, we don't have anyone that can have a look. I'm happy to provide you with as much info as required, what would you need? – user757392 Oct 26 '18 at 9:54
  • Is it just me or do people still not get notified when a comment like this is posted to a question they've commented on? I surely didn't get a notification about Tim leaving a comment on my thread. This has happened to me before, so annoying! – user757392 Oct 26 '18 at 13:16
  • Your best bet is probably to hire someone to poke around and have a look at it. Poking around for 30 minutes would be more efficient than posting screenshots, but also more expensive. You can post screenshots that show the instance, instance status screenshot (it's in the console), the VPC, NACLs, security groups, internet gateway, in a way that makes it obvious how they're associated. You could also try spinning up another instance in the same subnet to see if you can connect to it, then on to that instance. – Tim Oct 26 '18 at 23:02
  • 1
    @Tim I forgot to mention that this issue is actually with a business, I was just the employee that messed it up really... – user757392 Nov 1 '18 at 11:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.