2

I have an HP MicroServer that I use for dev/test. I've successfully installed Windows 2019 Server Standard on it (a dozen times now!) - and everything works great until I add the Hyper-V role. (This server was previously running Windows Server 2016 with Hyper-V with no issues.)

Once I add the Hyper-V role, and reboot, the thing just goes into a boot loop. When the boot loop happens, there is no BSOD, just a reboot every time. I've tried to boot into "safe mode" and remove the role, but even after doing that, it just continues in a reboot loop. After a few failed boots, it'll kick into the automatic repair screen, and that appears to be no help.

What is the best way to troubleshoot this and get Hyper-V installed? I've tried adding the role via the server manager, powershell, the new Windows Admin Center - and have the same results every time. Am I missing some sort of prerequisite for Hyper-V that the installer isn't adding automatically?

2

In fact Windows 2019 is very buggy now. I would suggest avoiding it for now and wait for the new stable release.

According to the Microsoft Evaluation Center:

"We have temporarily removed all media for Windows Server 2019 and Windows Server, version 1809. We have also paused the rollout of the latest feature update to Windows 10 inclusive of versions 1809, as we are investigating isolated reports of users missing some files after updating. If you have already downloaded media, please don’t install it and wait until more information is available to proceed. We apologize for any inconvenience this may have caused. We will provide an update when refreshed media is available. For reference, we also have a support article with additional information."

However, you can try a possible workaround - install Windows 2019 in BIOS (Legacy) mode instead of UEFI and then Hyper-V should not cause the boot loop.

  • 1
    Yes - i'm aware of those issues. Since I was wiping the machine, none of the upgrade data loss issues affected me. This machine does have BIOS instead of UEFI - i'm unaware of any "mode" to choose during the install, am I missing something? – Scott Ivey Nov 5 '18 at 14:56

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.