1

I run https://podnews.net through AWS, and use their SNI SSL certificates. This appears to work fine for everyone.

For the newsletter software, my click throughs go through https://sendy.amazinglybrilliant.com.au which is a Lets Encrypt certificate running on an Amazon EC2 instance. Some people (perhaps 5%) complain that none of these links work.

I've tried looking at both these sites through an SSL checker, but can't see any obvious reason why the Amazon one would work, but the LetsEncrypt one wouldn't.

One user is using Chrome on a Mac, through a corporate internet connection. The error message he gets is ERR_CONNECTION_RESET

What should I be looking for here? I'm confused why they both work differently; SNI issues should cause both to fail.

  • 1
    You need to gather basic system information from the people who are complaining. – Michael Hampton Oct 27 '18 at 2:49
  • @michael You're right. One of them is using Chrome on a Mac, through a corporate internet connection. The error message he gets is ERR_CONNECTION_RESET . I'll add this to the main question. – jamescridland Oct 27 '18 at 2:52
  • 3
    That person should first talk to their internal IT support. It's very unlikely that the problem is on your end. You can try pulling log entries for their IP address, but you aren't going to find anything useful. – Michael Hampton Oct 27 '18 at 3:08
  • @michael I don't understand, though, why Podnews works but the Sendy one doesn't. There doesn't seem to be any material difference. – jamescridland Oct 27 '18 at 3:20
  • 1
    Your server supports TLS 1.0 - 1.2, but not the old and insecure SSL 2 /3. Could that 5% still be using that incredibly old protocol? Certs otherwise look fine. Your website isn't on any blacklist I can see. You need more detail from the people having problems. – Tim Oct 27 '18 at 7:40
2

I found this thread as I was researching why I was one of the 5%. Looks like my ASUS router uses the Trend Micro database for flagging malicious sites. You can look it up here:

https://global.sitesafety.trendmicro.com

Looks like https://sendy.amazinglybrilliant.com.au is currently flagged as safe, but spam:

Trend Micro Lookup for sendy.amazinglybrilliany.com.au

Maybe submitting a reclassify request would help?

  • Many thanks. And yes, this is the reason - there's probably a message on the Trend Micro redirect that it attempts to take you to, but nobody can see it. – jamescridland Feb 11 at 5:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.