0

I changed the eth0 MTU size to 1550(using : ifconfig eth0 mtu 1550) and ran ping -c 1 -M do -s 1500 -w 5 {some other IP} and

The output I see is,

--- x.x.x.x ping statistics --- 5 packets transmitted, 0 received, 100% packet loss, time 4001ms

The failure here is because Ethernet supports only MTU 1500. Now if run ping -c 1 -M do -s 1472 -w 5 {some other IP} with the "other IP" host powered off, I get the same output.

How do I find the reason of 0 received, 100% packet loss? Was it because of MTU issues or that the host was powered off?

  • You go look at the other host. That is it. – Michael Hampton Oct 28 '18 at 20:37
  • There's no definitive way for you to know. It could be because of the mtu BUT it could also be because the host is powered off BUT it could also be because ICMP Echo Request is blocked at the host or somewhere before the host. – joeqwerty Oct 28 '18 at 20:41
  • @MichaelHampton Is there a command which can tell me the pathMTU and also differentiate if the Host is powered off? – PleaseHelp Oct 28 '18 at 20:42
  • @joeqwerty Some other command to tell the pathMTU and also differentiate if the Host is powered off? – PleaseHelp Oct 28 '18 at 20:44
  • 1
    How could any command or tool tell you if the host is powered off? There's no definitive way to know that without having access to the host. – joeqwerty Oct 28 '18 at 20:46
2

You can try traceroute --mtu <host> on a Linux system. This will cause traceroute to start with 65000 byte jumbo frames and decrease their size based on Path MTU discovery.

But while this may point out MTU problems in your network, it is still no guarantee that you can determine whether a host is powered on. It may be dropping these packets rather than responding to them, for instance. It also might not tell you if you have an MTU problem with a directly connected host on the same link.

  • By "same link" do you mean the same physical link? Also, I tried traceroute in my network, apparently it allows 65000 byte jumbo frames :| – PleaseHelp Oct 28 '18 at 21:08
  • Yes, 'same link' means the same layer 2 network. – Michael Hampton Oct 28 '18 at 21:10

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.