I am setting up a NAS with 8 known-good 8TB WD Red drives from a previous NAS. When I configure RAID 6 across these drives my (untested) LSI MegaRAID 9265-8I starts beeping and reports that that drive is bad. However, when I run WD's LifeGuard Diagnostics it reports that all of the SMART tests pass.

MegaRaid failure event as reported by MegaCli:

Code: 0x00000191
Class: 2
Locale: 0x02
Event Description: Diagnostics failed for PD 18(e0xfc/s7)
Event Data:
Device ID: 24
Enclosure Index: 252
Slot Number: 7

Things I have tried so far:

  • Erasing the "Bad" drive completely
  • Setting the "Bad" status to "Good" and reconfiguring the array
  • Swapping the SFF and sata cables (the same drive failed in any position)

Anyone know what else I should try or if I am likely looking at a bad drive or a bad RAID controller?

  • 1
    The fact the same drive shows failed in any position is pretty damning to me, especially as they're all the same drive
    – Dan
    Oct 28, 2018 at 22:02
  • I was wondering if maybe the controller's SMART tests are more strict that WD's, which will suck because it will likely mean I can't RMA the nearly new drive. Oct 28, 2018 at 22:04
  • How are you running the WD diagnostics? Did you reconnect the drive directly to the motherboard? Oct 28, 2018 at 22:15
  • I attached it directly to at the motherboard of a windows machine (the NAS is a headless Fedora Server). Oct 28, 2018 at 23:54
  • 1
    Run the extended self test. This will take several hours. If there is a problem with the drive, it ought to fail during the extended self test. If not, edit your question and add the SMART attributes. You may find it easier to copy and paste these from Linux. Oct 29, 2018 at 0:05

1 Answer 1


The issue ended up being a bad RAID controller. I briefly came to the conclusion that it was a cable issue due to swapping the cables and having the "bad" drive change slots but eventually realized that the controller was remembering the "bad" drive. Further swaps of the cables and re-configuration showed that it was always slot 7 that failed no matter what drive or cable was used.

After installing a known good MegaRAID controller I had to hand, I was able to successfully configure a RAID 6 array with all 8 drives. The bad raid controller will be returned and replaced.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .