0

I'm trying to use git push or ssh -Tv git@bitbucket.org but the server is blocking the connection.

I don't have ufw of iptables istalled... so what is blocking the connection... is there any log? can i disable the firewall?

Thanks EDITED:


The server is a VM taht runs: No LSB modules are available. Distributor ID: Debian Description: Debian GNU/Linux 9.5 (stretch) Release: 9.5 Codename: stretch

if i run telnet bitbucket.org 22 hangs if i run ssh -Tv git@bitbucket.org hangs

ping 8.8.8.8 runs as expected:

ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
From 192.168.2.253: icmp_seq=1 Redirect Host(New nexthop: 192.168.2.54)
64 bytes from 8.8.8.8: icmp_seq=1 ttl=122 time=18.0 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=122 time=16.9 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=122 time=16.6 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=122 time=16.4 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=122 time=16.4 ms
^C
--- 8.8.8.8 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4005ms
rtt min/avg/max/mdev = 16.416/16.895/18.018/0.615 ms

What is weird is that ping bitbucket.org lost all the packages but ping shows something like redirect:

PING bitbucket.org (18.205.93.2) 56(84) bytes of data.
From switchhp.example.fr (192.168.2.253): icmp_seq=1 Redirect Host(New nexthop: 192.168.2.54 (192.168.2.54))
  • This doesn't look like a firewall issue, it looks like a networking issue. Check if your machine's IP address, netmask and default gateway are correct. Ask your service provider for the correct information. – Michael Hampton Oct 31 '18 at 15:59
0

this may happen for a several reason:

  1. the server rejects you because the ssh port is closed by iptables.
  2. the server rejects you because it allows you to make ssh connection based on your public key.
  3. the server rejects you because you don't have the permissions to write on the repository.
  4. etc

please explain more, what you see when you make ssh connection with -v option.

  • Question updated and i remove iptables and ping is loosing all the packages – 3pepe3 Oct 31 '18 at 15:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.