2

Below, all error messages etc. are given here as translated by myself from German. The English original may differ

We have the following setup

  • Server A: Windows 2016 with RDP Session Broker and RDP Licensing for two RDP farms
  • Server B1, B2, ...: Windows 2016, RDP Session Host, members of first RDP farm
  • Server C1, C2, ...: Windows 2016, RDP Session Host, members of second RDP farm

Until recently, I could manage the farms (e.g., disable logins for single farm members, manage and shadow user sessions, ...) from Server A and its Server Manager. However, today the following happens and I cannot get rid of it:

On Server A, in Server Manager, I have A, B1, B2, ..., C1, C2, ... in the server pool (i.e., listed under "All Servers" as well as under "Remote desktop Services" - "Servers").

  • When selecting Remote Desktop Services, the menu shows "Overview" and "Servers", whereas the expected behaviour is that there should be a third item "Collections" with the two farms as sub-items

  • In "Overview", it says

    There is no remote desktop server deployment in the server pool. In order to create a deployment, run the wizard to install roles and features and select "remote desktop services".

    However, all that I think is needed, is already installed: the role remote Desktop Service (with sub-roles licensing, session host, session broker, web access)

Just for fun, I went to another server (Server B1), started Server Manager, added the same servers to the server pool, and - voilà! - everything works there ("Overview" shows the graphical overview etc., "Collections" has all farms below it, I can configure and manage the farms and their member servers as well as individual sessions)

On Server A, I tried to remove some of the session hosts from the server pool. Then "Overview" correctly noticed that these were missing and urged me to add them to the server pool, which I did. But the original problem did not go away. Of course I also rebooted server A, but that did not help, either. EventLog shows nothing of interest.


Q: What got broken on Server A?


Update: Doing more research, also including hints from the comments, I tried the following: In Add Roles and Features, I pick "Installation of RDP" and am told "There already is a Remote Desktop Deployment in the server pool ...", so the exact opposite of what the messages say elsewhere! Any attempts to continue, however, (no matter if standard or quickstart or multipoint) lead to an error "Deployment information could not be retrieved from RD connection broker 'Server A'"

  • 1
    Can you try to open Server Manager with another user on Server A ? Something may be broken in your profile only. – Swisstone Nov 4 '18 at 15:08
  • @Swisstone I logged on with a different user. Session Manager of course asked me to add the necessary servers to the server pool. I did that, and then the same problem occurs with this user. So I guess it is not user-specific – Hagen von Eitzen Nov 4 '18 at 17:26
  • Doing a quick google search there is a crap ton of 2012 issues with RDS and Server Manager (try the google search: 2016 Server Manager missing collections). There seems to be a lot of issues, some of them revolving around AD permissions on the object ... I know this isn't specifically helpful but I don't have a real answer here. Just a comment. – Joseph Kern Nov 11 '18 at 18:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.