0

I have recently migrated 30 websites from my old server to new one, and now running on nginx as previously was running on apache.

Everything works fine for all websites except for 1 website.

I don't know why, but I get these message on log file /var/log/php7.2-fpm-example.log :

[09-Nov-2018 14:58:35] NOTICE: systemd monitor interval set to 10000ms
[10-Nov-2018 03:35:51] WARNING: [pool cappatrimonial] server reached max_children setting (5), consider raising it
[10-Nov-2018 06:30:09] WARNING: [pool cappatrimonial] child 4727 exited on signal 7 (SIGBUS) after 10458.281970 seconds from start
[10-Nov-2018 06:30:09] NOTICE: [pool cappatrimonial] child 13790 started
[10-Nov-2018 09:35:35] NOTICE: Terminating ...
[10-Nov-2018 09:35:35] NOTICE: exiting, bye-bye!
[10-Nov-2018 09:35:37] NOTICE: fpm is running, pid 31266
[10-Nov-2018 09:35:37] NOTICE: ready to handle connections
[10-Nov-2018 09:35:37] NOTICE: systemd monitor interval set to 10000ms
[10-Nov-2018 10:39:56] WARNING: [pool cappatrimonial] server reached max_children setting (10), consider raising it

As you can see above, I have already increased max_children setting from 5 to 10 and message appears again. Also, the problem can be every 3 hours or every 10 hours..there is no logic.

On nginx error log file /var/log/nginx/example.error_log I have found this :

2018/11/10 09:35:35 [error] 16088#16088: *77278 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: server_ip_address, server: www.example.com, request: "GET //erreur-404 HTTP/1.1", upstream: "fastcgi://unix:/var/run/php/php7.2-fpm-example.sock:", host: "www.example.com"

2018/11/10 09:35:35 [info] 16088#16088: *77280 client server_ip_address closed keepalive connection (104: Connection reset by peer)

What's wrong ?

Below is my php-fpm configuration for this website :

[global]
pid = /var/run/php/php7.2-fpm-example.pid
error_log = /var/log/php7.2-fpm-example.log

[example]
user = example
group = example
listen = /var/run/php/php7.2-fpm-example.sock
listen.owner = www-data
listen.group = www-data
php_admin_value[disable_functions] = exec,passthru,shell_exec,system
pm = ondemand
pm.max_children = 10
pm.process_idle_timeout = 20s

I really don't understand why this appears only for this website and not others.

Do you have any idea because I'm lost :-/ ?

Many thanks

  • IDK but its possible your children are being consumed by a bad PHP script. The URI //erreur-404 looks strange because of the two leading /s. You may want to look at the PHP script that's processing it. – Richard Smith Nov 10 '18 at 12:12
  • Ok I will have a look on php side. Other suggestions ? – TooNetCreation Nov 10 '18 at 12:22
  • Uninstall the PHP apcu extension if it is present. – Michael Hampton Nov 10 '18 at 13:03
  • This is the origin of the problem from your point or view ? – TooNetCreation Nov 10 '18 at 14:15
  • @MichaelHampton : if I run php -m command, there is no apcu extension displayed. the same if I run php -m | head command. – TooNetCreation Nov 10 '18 at 16:53
0

problem was due to bad php script as suggested by @Richard Smith

I have updated website and works fine now.

thanks

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.