1

I recently migrated from one server where my mail settings worked without a problem to a new server which now results in the following error:

Server responded: 503 AUTH command used when not advertised\r\n.

The full SMTP log is:

19:16:12 [MailBee SMTP v. 5.3.0.47. Registered version]
19:16:12 [Connecting to server mail.example.co.uk at port 25 using default domain]
19:16:12 [Domain specified in FromAddr, example.co.uk used]
19:16:12 [Entering ESMTP authentication mode]
19:16:12 [Sending ehlo]
19:16:12 [Using PLAIN ESMTP authentication]
19:16:12 [Error: Negative or void server response]
19:16:12 [Server responded: 503 AUTH command used when not advertised\r\n]
19:16:12 [Possible error reason: PLAIN authentication type (auth plain command) is not supported by this server]
19:16:12 [Error: Connection failure]
19:16:12 [Error: Not connected]

Please could someone point me in the right direction as to why this is failing.

  • Can you get that "MailBee" program to somehow produce more verbose logging, for instance of the actual SMTP session? There is much detail not present in these logs. If not, try connecting to the mail server yourself e.g. with nc and see what the banner response is. – Michael Hampton Nov 10 '18 at 22:50
  • @MichaelHampton thanks for your answer. Having now had a chance to run nc it appears the server is not advertising AUTH as shown below hence the '503 AUTH command used when not advertised.' – Ross Hodgman Nov 13 '18 at 0:41
  • (xxxx used to obfuscate server address for security purposes.) nc: Cmd line: mail.example.co.uk 25 220-xxxx.servers.xxxx.xxxx.co.uk ESMTP Exim 4.91 #1 Tue, 13 Nov 2018 00:47:05 +0000 220-We do not authorize the use of this system to transport unsolicited, 220 and/or bulk e-mail. EHLO mail.example.co.uk 250-xxxx.servers.xxxx.xxxx.co.uk Hello host86-191-168-7.range86 191.btcentralplus.com [86.191.168.7] 250-SIZE 52428800 250-8BITMIME 250-PIPELINING 250-STARTTLS 250 HELP AUTH LOGIN 503 AUTH command used when not advertised. – Ross Hodgman Nov 13 '18 at 0:51
  • Are you actually trying to send authenticated mail? That goes on port 587, not port 25. – Michael Hampton Nov 13 '18 at 1:01
  • @MichaelHampton I've now tried port 587 but have got the same error message as before. – Ross Hodgman Nov 13 '18 at 12:15
0

You cannot use AUTH when the server don't allow you to. The server would say something like

250-AUTH PLAIN LOGIN

if you would be allowed to. In your comment it's also visible that the server haven't advertised SMTP auth so using it violates protocol.

The most probable reason is security: the server announces STARTTLS and most probably expects you to use TLS (encrypted/secure connection) before you try to use a non-encypted authentication, basically protecting you from negligent behaviour.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.