2

** Problem

We are attempting to run a self-extracting executable (SFX) to install an Oracle product, Oracle Enterprise Manager 13.2. The installation starts, works for a short while, and then quits, cleaning up after itself, but with no error messages or log files explaining why the installation was not performed.

** Environment

Windows 2016 (Windows NT 6.2), No service pack. Clean install of VM with customer-required hardening applied. All hardware and (known) software requirements met. OS is vendor-certified (I.E., Oracle says this should work on Windows 2016). Checksums are validated on all downloaded files.

** Details

The complete set of downloaded installation files includes the SFX "setup_em13200_win64.exe" and five additional zip files.

The SFX contains a folder named Disk1 and an autorun.inf file.

Each of the five additional zip files contains a single folder named Disk2, Disk3, ..., Disk6.

When executed, the SFX should take the following steps:

(Works) 1. In the location specified by the TEMP environment variable, create a working folder with an arbitrary name.

(Works) 2. In the working folder, create a folder called Disk1 and an autorun.inf file.

(Fails at this point, the next steps are from analyzing the results of running the SFX on my laptop.)

  1. In the working folder, extract the other associated zip files to create Disk2, Disk3, ..., Disk6 folders.

  2. In the working folder, create an "oracle.jdk" folder and place a 1.7 JDK in it.

  3. Launch the Oracle Universal Installer (a jar file) using the JDK installed in oracle.jdk.

Steps 1 and 2 work, but the process aborts and cleans up after step 2. There are no error messages.

  • The process works on my laptop and on a 2016 server that has no customer-required hardening applied and is not attached to the domain.

  • The process did not work on other 2016 servers in the domain (we tried three).

  • The process does not work even when we disjoin the server from the domain (which should remove the GPO and other hardening, we think).

** Conclusion

We have tried many approaches to fix this with no success. The only thing that works so far is to manually extract the files, set up some environment variables, and run the Oracle installer manually. While that appears to be a viable workaround, this is a production environment and our preference is to understand what is making the SFX stop when it tries to unzip the other archives.

Earlier post on the Oracle community boards is here: https://community.oracle.com/message/14985804

Any suggestions are appreciated.

Thank You!

-Tom

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.