0

I'm working on reconfiguring an existing production server and having trouble with a dual port Intel PCIe card. It's running CentOS 6.4 [2.6.32-358.23.2.el6.x86_64] and it seems like it's a driver issue on the 2nd NIC as it's detected by the system.

There was a bond interface that I believe at some point both these Intel NICs have been members of (I say this due to some of the comments in the old interface config files). That being said, when I came to reconfigure the network, only eth0 was a member of the bond and eth1 is/was nowhere to be seen. I've since removed the bond interface.

Here's what I've done so far;

  • NetworkManager isn't running, just using the CentOS network service
  • Both Interfaces are listed with lspci
  • Deleted the 70-persistent-net.rules file and rebooted
  • Manually modifying 70-persistent-net.rules with the MAC ADDR of eth1

Here is some more output showing why I think it's a driver issue, though I'm struggling to resolve that.

# lspci|grep -i net
  03:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5719 Gigabit Ethernet PCIe (rev 01)
  03:00.1 Ethernet controller: Broadcom Corporation NetXtreme BCM5719 Gigabit Ethernet PCIe (rev 01)
  03:00.2 Ethernet controller: Broadcom Corporation NetXtreme BCM5719 Gigabit Ethernet PCIe (rev 01)
  03:00.3 Ethernet controller: Broadcom Corporation NetXtreme BCM5719 Gigabit Ethernet PCIe (rev 01)
  04:00.0 Ethernet controller: Intel Corporation 82599EB 10-Gigabit SFI/SFP+ Network Connection (rev 01)
  04:00.1 Ethernet controller: Intel Corporation 82599EB 10-Gigabit SFI/SFP+ Network Connection (rev 01)

04:00.1 is the culprit

# find /sys|grep drivers.*04:00
  /sys/bus/pci/drivers/ixgbe/0000:04:00.0  

I figure it's a driver issue due to 0000:04:00.1 not being listed with the above.

# ifconfig -a
  eth0      Link encap:Ethernet  HWaddr 90:E2:BA:17:XX:XX  
            inet6 addr: fe80::XXX/64 Scope:Link
            UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
            RX packets:19695 errors:0 dropped:0 overruns:0 frame:0
            TX packets:124 errors:0 dropped:0 overruns:0 carrier:0
            collisions:0 txqueuelen:1000 
            RX bytes:1999668 (1.9 MiB)  TX bytes:9176 (8.9 KiB)

  eth2      Link encap:Ethernet  HWaddr D8:9D:67:32:XX:XX  
            UP BROADCAST MULTICAST  MTU:1500  Metric:1
            RX packets:0 errors:0 dropped:0 overruns:0 frame:0
            TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
            collisions:0 txqueuelen:1000 

  eth3      ...
  eth4      ...
  eth5      ...
  lo        ...

Any assistance is much appreciated, thanks.

  • 2
    You're several years behind on updates. Install them. – Michael Hampton Nov 14 '18 at 12:48
  • @MichaelHampton I've done a yum update, now running CentOS 6.10. Still the same issue. I'm going to try booting into a livecd when I get a chance. Please let me know if you have any other suggestions. – Huckleberry Finn Nov 16 '18 at 11:00
  • Just booted into a Linux Mint 18 LiveCD and it too only detects one of the interfaces. Oddly I can see light coming from the SFP+ module, and when hooking up a fibre cable the lights at the rear show activity. Does anyone have any ideas? I might try updating the BIOS now - it's an HP DL360 G8. – Huckleberry Finn Nov 16 '18 at 11:37
  • 1
    Check dmesg to see if any problems were noted when bringing up the interface. Now it sounds likely that you have a defective NIC. – Michael Hampton Nov 16 '18 at 15:22
  • @MichaelHampton Thank you for the suggestion, that pointed me to the answer! – Huckleberry Finn Nov 20 '18 at 15:50
0

This was caused by having an unsupported SFP module installed in the second port.

Thanks to Michael Hampton's suggestion of checking dmesg I was able to find this line;

ixgbe 0000:04:00.1: failed to load because an unsupported SFP+ or QSFP module type was detected.
ixgbe 0000:04:00.1: Reload the driver after installing a supported module.
ixgbe 0000:04:00.1: PCI INT B disabled  

After installing a supported transceiver and rebooting, the interface then came up as expected as eth1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.