No templates are shown in the Template folder of the Certificate Authority.

In the Certificate Templates (certtmpl.msc) are Templates shown.

Running certutil -CATemplates returns 0x80070490 (WIN32: 1168 ERROR_NOT_FOUND) CertUtil: Element not found.

Restarting the service did not help

Sreenshot of CN=OID shows the following result

enter image description here

There are also no entries under CN:Enrollment Services

enter image description here

  • Does CN=OID container has entries in Active Directory? You can view them in ADSI Edit (adsiedit.msc) under CN=OID, CN=Public Key Services, CN=Services,{configurationNamingContext} container. – Crypt32 Nov 17 at 16:06
  • See update in question – Mister 832 Nov 17 at 16:12
up vote 5 down vote accepted

It looks like that your templates are ok and OIDs are ok as well.

Try to restart certificate service (certsvc) on new CA and check if templates are loaded. If this doesn't help, then stop certsvc on CA, then remove templates in CA record under CN=Enrollment Services, CN=Public Key Services, CN=Services,{configurationNamingContext}. Open CA record, navigate to certificateTemplates attribute:

  1. record a list of certificate templates you see them (just write somewhere).
  2. clear list by removing all entries from this attribute.
  3. Open Certification Authority MMC snap-in (certsrv.msc), start certsvc and try to add templates manually from the record you made in step 1.
  • Sorry, but does new CA mean, I should reinstall the certificate Authority? – Mister 832 Nov 18 at 8:59
  • Where did I say about new CA? – Crypt32 Nov 18 at 9:01
  • Sorry, I misread it. Well, stopping an restarting certsvc did not help. BTW: Thank you for your good answer! – Mister 832 Nov 18 at 9:06
  • I've deleted the objects under CN=Certificate Templates. After that, when I select Templates in CA, I asked if I wanted to reinstall the templates, since none where found. However, after that, the CA Templates did still not appear. If I right-click on Template-->New, the option template is disabled.So, I've created one pKICertifacte in ADSI-Editor. Restarted the service, but the result was still the same. The Template does not show up – Mister 832 Nov 18 at 9:14
  • You did everything wrong. I asked to delete a list of certificate templates from attribute ander CA record in Enrollment Services container. I didn't say anything about Certificate Templates DS container. Also, I didn't ask to restore the list of templates in ADSI Editor, I asked to do this from Certification Authority MMC snap-in. – Crypt32 Nov 18 at 9:36

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.