Yesterday one of my pools which is a mirror was degraded - one of two 2TB disks failed. I replaced the failed one with another disk 4TB (ada3). Now I want to add another 4TB disk (ada1) to enlarge the size of the mirror to 4TB. But unfortunately, instead of just attaching the ada1 to the existing mirror, by stupidity I detached the 2TB disk (ada2) from the pool. Here is the current status:

# zpool status
  pool: vm
 state: ONLINE
status: Some supported features are not enabled on the pool. The pool can
    still be used, but some features are unavailable.
action: Enable all features using 'zpool upgrade'. Once this is done,
    the pool may no longer be accessible by software that does not support
    the features. See zpool-features(7) for details.
  scan: resilvered 1.10T in 7h1m with 0 errors on Tue Nov 20 01:37:50 2018
config:

    NAME        STATE     READ WRITE CKSUM
    vm          ONLINE       0     0     0
      ada3      ONLINE       0     0     0

errors: No known data errors

Now, when I attach the ada3 to the pool zpool says:

# zpool attach vm ada3 ada1
cannot attach ada1 to ada3: no such pool or dataset

I tried specifying the absolute path to the device (/dev/ada3, /dev/ada1) with no luck.

How can I correctly attach ada1 to the pool to create a mirror? Do I correctly understand that if I add ada1 to the pool like so Code: zpool add vm mirror ada3 ada1 zpool will create another mirror and the existing data in ada3 will be destroyed? ada1 is a brand new disk with nothing in it. Thank you.

  • Are you sure this zpool was originally a mirror? It doesn't look like it ever was. It shows a single device, not a mirror with one of its devices missing. Did you do something to the pool that you haven't yet mentioned here? – Michael Hampton Nov 20 at 13:26
  • I was a mirror. After detaching one disk from it, it became a non-redundant pool with one disk, so the status mirror was not shown. I was able to solve the problem booting into the single-user mode. – conqueror Nov 20 at 21:14

I was able to attach the new disk booting into the single-user mode and using the same attach command. The order of how disks appeared in the system was the same. Using attach with the guid retrieved by the zdb command gave the same error. Still could not understand why the command would not work in the multi-user mode.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.