Id very much like to do this but it doesn't seem to be enabled on my installation.

# rpm -qa | grep pdns

Ive tried both iterations in pdns.conf (enable-lua-record and global-lua-record) to the same effect:

pdns_server[5685]: Fatal error: Trying to set unknown parameter 'enable-lua-record'

It this to be slated for v4.2? Seems to be some mixed signals out there as to whether or not it's currently available.

Also - v4.2 doesn't seem to have a release schedule. The last info I found was from 10/2017 referring to a beta. Is the current 'master' build of reasonable stability? The ultimate goal is to enable round-robin DNS and this (via LUA) seems to be the only avenue.

EDIT: some possibility here. I wish they had included the actual records they used.


The config option seems to be enable-lua-records (note the "s").

  • Nice catch. I tried that and got the same error though. Fatal error: Trying to set unknown parameter 'enable-lua-records' – ethrbunny Nov 21 '18 at 21:54

FWIW - I did a build from master and was able to implement LUA records. I can already see where this feature will be v useful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.