0

I would like to get help with my Ubuntu desktop 18.04.01 .

I just installed Ubuntu 18.04.01 running top of kvm (fedora server 28) and having hard time setting up dns access.

While diagnosing why DNS queries from Ubuntu desktop is not responded from my router, I found below packets was sent from Ubuntu.

12:29:53.596586 IP 192.168.11.100.45415 > 192.168.11.1.domain: 31141+ AAAA? ntp.ubuntu.com. (32)
12:29:53.597703 IP 192.168.11.100.37220 > 192.168.11.1.domain: Flags [S], seq 574811215, win 29200, options [mss 1460,sackOK,TS val 3560337742 ecr 0,nop,wscale 7], length 0
12:29:53.597902 IP 192.168.11.100.37222 > 192.168.11.1.domain: Flags [S], seq 3169117583, win 29200, options [mss 1460,sackOK,TS val 3560337742 ecr 0,nop,wscale 7], length 0
12:29:53.598020 IP 192.168.11.100.37224 > 192.168.11.1.domain: Flags [S], seq 4965594, win 29200, options [mss 1460,sackOK,TS val 3560337742 ecr 0,nop,wscale 7], length 0

What is this SYN request from Ubuntu desktop ?

Best Regards, Yu Watanabe

  • 2
    Those look like DNS over TCP queries to me. The Ubuntu desktop is trying to establish a TCP session with the DNS server for the purpose of issuing a DNS query to the DNS server. – joeqwerty Nov 25 '18 at 4:08
  • And it might try connecting with TCP because UDP DNS is not available. – Tero Kilkanen Nov 25 '18 at 13:20
  • I see . This is interesting. – Yu Watanabe Nov 27 '18 at 9:11
0

Thank you for the answer. Joeqwerty and Tero Kikanen.

So the cause of the TCP packets was that Ubuntu (Guest OS) was unable to communicate with DNS.

However, root cauase of this problem was the bridge interface was not sending out dns packets from guest OS to the dns server. I use kvm on fedora sever 28 and Ubuntu runs on top of it.

In my case I disabled the netfilter for the bridge interface.

https://wiki.libvirt.org/page/Networking#Creating_network_initscripts

The final step is to disable netfilter on the bridge:

 # cat >> /etc/sysctl.conf <<EOF
 net.bridge.bridge-nf-call-ip6tables = 0
 net.bridge.bridge-nf-call-iptables = 0
 net.bridge.bridge-nf-call-arptables = 0
 EOF
 # sysctl -p /etc/sysctl.conf

Now TCP packets are not sent out.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.