2
ssh -D 9090 user@host

when I try to request web pages through socks5 (127.0.0.1:9090) I get:

channel 3: open failed: administratively prohibited: open failed

server sshd_config:

#MaxStartups 10:30:100
PermitTunnel yes
#ChrootDirectory none
#VersionAddendum none

# no default banner path
#Banner none

# Accept locale-related environment variables
AcceptEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES
AcceptEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT
AcceptEnv LC_IDENTIFICATION LC_ALL LANGUAGE
AcceptEnv XMODIFIERS

# override default of no subsystems
Subsystem       sftp    /usr/libexec/openssh/sftp-server

# Example of overriding settings on a per-user basis
#Match User anoncvs
#       X11Forwarding no
        AllowTcpForwarding yes
        PermitTTY yes
#       ForceCommand cvs server
#       PermitTunnel yes
        GatewayPorts       yes

what I am missing?

0

I realize that this is an old question ... but in case someone lands here via Google.

Check out https://unix.stackexchange.com/questions/14160/ssh-tunneling-error-channel-1-open-failed-administratively-prohibited-open It has a number of suggested fixes.

By the way, why did you post a question when this question has been asked many times?

1
  • I actually don't remember :), I guess I wanted to share the config file, because it looked okay to me but didn't work. Apr 7 at 6:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.