I'm having trouble with SSH sessions between two laptops on my network, A and B.

A is a laptop I bought recently. B is the laptop it replaced.

When I purchased A, I cloned B's hard drive. A thus has the name that B used to have, and I gave B a new name by editing /etc/hostname and the name of in /etc/hosts.

I built new ssh host keys on B and also a new ssh key for my user account there.

On a separate device, I run DHCP and DNS servers, and I reserve addresses for most of my devices. B's Wi-Fi interface had a reservation for x.x.x.10. I changed B's reservation to x.x.x.23 and gave the .10 address to A's Wi-Fi interface.

The problem I'm having is that whenever I try to connect via ssh from A to B or from B to A, the SSH session freezes after all the handshaking and negotiating.

I have no problem ssh-ing to or from either of these machines and any other device on the network. But on B, I've even installed Windows (fresh) as a dual boot OS, and from Cygwin, when I try to ssh to A, I have the same problem.

I've cleared the ARP cache on these machines and every other one on my network, but to no avail. I have no trouble running iperf between the two machines, and I can host a simple web application on one and view it on the other. I don't know what's going on with SSH.

It has to have something to do with the Wi-Fi connection, though, because if I connect the two laptops together with an Ethernet cable and give them static IP addresses, I have no problem with SSH over that interface.

I shut down the sshd daemon on B and ran this:

sudo /usr/bin/sshd -ddd 2>daemon.log

Then on A, I ran this:

ssh -vvv B 2>client.log

The resulting daemon and client logs don't reveal anything obvious to me, but maybe they will to someone else.

  • What if you run a tcpdump and analyze the network traffic? Nov 27, 2018 at 1:14
  • @MikeMarseglia: Everything looks fine at first (as far as I can tell), then I get a handful of retransmissions from client to server. I haven't tried yet running tcpdump on the server.
    – P Daddy
    Nov 27, 2018 at 18:43

2 Answers 2


I started to see some other anomalies and came to the conclusion that my AP is acting up. A factory reset didn't solve it, so for the time being, I'm using my older AP. That seems to have resolved the issue, albeit at the cost of lower max bandwidth (since I've downgraded from 802.11ac to n). So I guess I'll be shopping for a new AP.

I'm not sure this question has much value for the community. If I get a couple of close votes or comments agreeing that it lacks value, I'll delete it.


Sounds like a network issue. I've had this happen when I clone virtual machines and the MAC address ends up the same on both. One time there were two machines on the LAN with the same IP and this also happened. You could try a tcpdump on the "daemon" host and see if it reveals anything. I think tcpdump -e will show the MAC in the packet. (eg: tcpdump -nn -s0 -A -e for lots of info)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .