0

I am administering a database server running SQL Server 2016. The MSSQLSERVER service has been running under a domain account (with a password that does not expire) for a long time now with no problems. Recently, the MSSQLSERVER service stopped and when I tried to restart it I got the following error:

Error 1069: The service did not start due to a logon failure

I tried re-entering the credentials for the domain account and restarted the service but that did not work. I even tried testing the SQL domain account to see if it can still log on by logging into a computer and it logged in without any logon failure. So the password is correct for the SQL domain account. What could be the reason that the MSSQLSERVER is not accepting the domain account credentials?

  • 1
    have you tested changing the account the service is running under? Try with a different (domain) account to fully confirm the scope of the problem, which it seems to be the current account. – Humberto Castellon Nov 27 '18 at 17:49
  • 1
    If you look at the SQL Server Configuration Manager, under the services, right-click and open up the properties of the service that isn't running. There will be a tab with startup parameters, one of these will be -e which points to where the errorlog is located. Go to that directory and locate the errorlog (no extension), open it up and see if there is anything written in there. Additionally, look in the application and system event logs around the time you start up the service to see if anything else is shown. – Sean Gallardy Dec 7 '18 at 4:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.