0

I have a Zabbix configuration problem here in the company a few days ago. I'm having this error on the hosts page in the Settings portion. I have already done several tests, being:

  1. Agent and Server Ports Release (Firewall Disabled)
  2. I changed the settings of agent.config and server.config.
  3. I disabled SELINUX.

If you can help me thank you, I only need this communication so I can proceed with the finalization of the installation.

Error: Received empty response from Zabbix Agent at [X.X.X.X]. Assuming that agent dropped connection because of access permissions.

I already looked for solutions in google but I did not find answers

UPDATE: I noticed that the server apparently has some network problem. I have managed to install normal zabbix using yum in Centos 7. However, the server is taking too long to ping google.com and is missing the settings in the resolv.conf file.

I do not know what this network problem can be, I'm a beginner in linux and I'm having a bit of trouble correcting this without having to configure a new server.

UPDATE 2: I identified that the server did not contain the google DNS (8.8.8.8) configured in: /etc/sysconfig/network-scripts/ifcfg-eth0 so I added this registry and it solved the network problem, now it's ping google.com , before of this was only the internal DNS of the company. But the initial problem still persists and I think there may be some relationship with network configurations

  • Your configuration of the agent itself, and the host on the Zabbix server would be helpful. Otherwise it's just blind guessing. – Gerald Schneider Nov 29 '18 at 12:30
  • Here's a Zabbix server and agent configuration: Server config Agent config – Luis Fernando Nov 29 '18 at 16:56
  • Run your agent in debug mode, it will greatly help you to find out what's wrong. – SBO Nov 30 '18 at 9:57
  • The log file was generated with debug level 5: LOG LINK – Luis Fernando Nov 30 '18 at 11:13
0

Error is in agent config SourceIP=192.168.17.197 is same as Server but this should be IP addrees of the client for outgoing traffic. Try comment this out or use client IP addres instead.

  • I tried to make this configuration in the agent commenting the SourceIP, restarting the zabbix agent and the server. The same error continued, in the "Settings > Hosts" screen, the "ZBX" is in red with the same message Perhaps a failure is occurring when the server connects to this agent, I have identified this message in the log, I do not know if it is generic: 1436: 20181130: 105232.029 Message from 192.168.17.197 is missing header. Message ignored. – Luis Fernando Nov 30 '18 at 12:53
  • Log of zabbix_server: 27435:20181130:104645.390 cannot send list of active checks to "127.0.0.1": host [DI-VZBX-197] not found – Luis Fernando Nov 30 '18 at 13:07
  • but 127.0.0.1 is localhost, it should be something like 192.168.17.XXX do you have 127.0.0.1 somewhere in the config? – Quantim Nov 30 '18 at 13:15
  • This address 127.0.0.1 was the one that was configured on Zabbix_agentd.conf on the server. Even changing to the IP of the server it continues with the same error. But this agent is the only one that communicates with the server (I think it's because it's local). The log that displays this error is the same server log. The agent I am trying to communicate (192.168.17.184) is a windows 10 and it does not have any configuration with 127.0.0.1, in the config of the server it also does not have the 127.0.0.1 – Luis Fernando Nov 30 '18 at 13:45

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.