4

Command:

yum install php php-cli php-gd php-curl php-mysql php-zip php-fileinfo php-mbstring

Gives following error:

Error: Package: php-cli-7.2.12-1.el7.remi.x86_64 (remi-php72)
           Requires: libargon2.so.0()(64bit)
Error: Package: php-7.2.12-1.el7.remi.x86_64 (remi-php72)
           Requires: libargon2.so.0()(64bit)

I have installed php earlier versions to Centos 7 before, but never encountered such a problem.

Where to start resolving this?

Centos 7 is a clean install, httpd and mariadb installed without problems.

I have tried:

yum clean all

yum distro-sync

Edit: PHP71 installed nicely, but I still need PHP72 in longer run.

9

The package you are missing is named libargon2, and it is in the epel repository. It was previously in remi until it was added to epel, at which point remi removed it from his repo.

In order to use the remi-php72 repo, you must also enable the remi and epel repos, but one or both of these are disabled on your system.

Enable the remi and epel repos and try again.

  • Because secure password hashes are a good idea for everyone :) – Michael Hampton Dec 2 '18 at 17:40
  • I mean, why they move stuff around and break things? Your answer explains, why I could upgrade my PHP71 to PHP72 without this problem. – Rauli Rajande Dec 2 '18 at 17:41
  • Most people would already have EPEL enabled, so wouldn't have noticed when they made this change. I didn't notice on any of my web servers. It's not well documented, but remi repo does require EPEL to be enabled. – Michael Hampton Dec 2 '18 at 17:44
  • 1
    @MichaelHampton "remi-safe" and "epel" should be enough for dependencies. Notice: remi-release have a dependency on epel-release, which make this requirement explicit. – Remi Collet Dec 3 '18 at 8:13
  • @RemiCollet Some people don't use the remi-release RPM and just create .repo files manually. For instance, if they are using configuration management like Ansible to mangle their systems, they might just install the corresponding .repo file and not also install remi-release RPM afterward. – Michael Hampton Jan 15 '19 at 5:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.