0

I have never used WebDAV before (I like sshf) but I am trying it. I want to mount a remote WebDAV share that I set up on my server, on my local computer.

If I try as non-priv user I can't access mount command fully.

If I try as root I can't access the folder as user. I used this command: sudo mount -t davfs -o noexec https://nextcloud.example.com/remote.php/webdav/ /mnt/dav/

I don't want to use /etc/fstab because I don't want the share to be mounted before I establish a VPN (but I do want mount -a in rc.local)

Is there something like -o idmap=user I can use for WebDAV?

Using Linux obviously.

  • I can't off-hand tell you why you can't issue the mount command is non-root user but: man mount.davfs shows a mount option uid=user The owner of the mounted file system. It may be a numeric ID or a user name. Only when mounted by root, this may be different from the mounting user. – HBruijn Dec 3 '18 at 8:07
  • @HBruijin I read that but obviously too quickly. I literally typed uid=user because I was used to -o idmap=user. I will try this again when I can come back to this issue. – stone.212 Dec 4 '18 at 7:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.