7

I've tried to import a *.pfx certificate and I get an error about "Wrong Password". The error only appears on some systems.

I've tested this on a few Windows 10 computers and on one Windows Server 2016.

  • Windows 10 (did not work): build 10.0.16299.0
  • Windows 10 (did not work): build 10.0.14393.0
  • Windows 10 (works): build 10.0.17134.0
  • Windows Server 2016 (did not work).

I've also tried to import the certificate with Powershell (with cmdlet below) and also results in the same error:

$mypwd = ConvertTo-SecureString -String "some-password" -Force –AsPlainText
Import-PfxCertificate –FilePath C:\tmp\Client.pfx cert:\localMachine\my -Password $mypwd

Import-PfxCertificate : The PFX file you are trying to import requires either a different password or membership in an Active Directory principal to which it is protected.

1
  • 1
    Looks like local permissions (NT user rights) were used while exporting the .pfx, not just the password.
    – bjoster
    Dec 5 '18 at 9:38
7

The error message is incorrect. The problem is that Win10 <= 1703 does not support importing SHA256 encrypted pfx certificates.

https://github.com/PowerShell/CertificateDsc/issues/153

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.