When trying to run sudo yum update I get

 --> Finished Dependency Resolution Error: Package: cinnamon-3.6.7-3.el7.x86_64 (@epel)
            Requires: caribou(x86-64)
            Removing: caribou-0.4.21-1.el7.x86_64 (@base)
                caribou(x86-64) = 0.4.21-1.el7
            Obsoleted By: gnome-shell-3.28.3-6.el7.x86_64 (base)
                Not found  You could try using --skip-broken to work around the problem

Firts I assumed it might be a repo problem and would be fixed, but after a week I started investigating. When checking http://mirror.centos.org/centos/7/os/x86_64/Packages/ I can see a package gnome-shell-3.28.3-6.el7.x86_64.rpm.

This lead me to check my yum configuration and I changed yum.repos.d so that it uses the central mirror and idsabled the mirrorlist:

name=CentOS-$releasever - Base

Afterwards I ran sudo yum clean all and sudo yum update, yet I still get the same error. What is wrong with my yum setup? Do I have to force yum to reread the configuration in another way?


The problem here is not that you have used the CentOS mirrorlist, and you can re-enable that.

The problem is that the Cinnamon desktop has been removed from EPEL as its package maintainer decided to stop maintaining it (long ago) and for several months no one stepped up to continue maintaining it.

You will need to remove the cinnamon package from your system to resolve the problem.

yum remove cinnamon
| improve this answer | |
  • That leaves me with one question: why do I see a package in the linked repository, but yum does not find it, even when using yum search? (Less pressing, how do you know about this issue, is there something like the news section on the archlinux page?) – ted Dec 6 '18 at 16:20
  • I just Googled it and found some chatter on the CentOS forum about it. – Michael Hampton Dec 6 '18 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.