0

I was looking at my event viewer in windows server 2003 earlier today when I noticed the Windows Remote Management did not load on bootup. I started checking into it and it's trying to logon as AUTHORITY\NetworkService when it's launching the service. I checked Active Directory and there is no AUTHORITY\NetworkService user added. Is there any way to re-add this user?

1
  • The windows 2003 server is a Domain Controller.
    – Jacob
    Dec 14 '09 at 21:30
2

NT AUTHORITY\Network Service is built into Windows and does not appear as a named account in the Local Users and Groups. http://support.microsoft.com/kb/243330.

Network Service is like the Local System account but has the ability to access network resources. There isn't a good way to change a service to use this account using the Services.msc console. Instead use the registry editor and browse to HKLM\System\CurrentControlSet\Services. In your service there will be string value named ObjectName. You can enter NT AUTHORITY\NetworkService as the value and restart your service. This may be a good place to start checking because if your error message doesn't include NT in NT AUTHORITY it may be that the value has been mangled.

1
  • I checked the registry of that service and it's correct. I changed the logon to "localservice" and the service ran fine. I just don't understand why the built-in Networkservice account is having problems all of the sudden.
    – Jacob
    Dec 14 '09 at 22:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.