0

I have mounted an ftp account to my linux folder using below command

curlftpfs -o user=userid:password ip-address /home/temp -o kernel_cache,allow_other,direct_io,umask=0000,uid=1000,gid=1000

The problem i am having is whenever I am trying to save data to any file on this mounted folder i.e. any text file it gives "Input/output error , unable to flush data " , afterwards the file is created in folder but data is not written to the file

Is there anything i am missing with the command? I am using below curlftpfs version

curlftpfs 0.9.2 libcurl/7.29.0 fuse/2.9

I also found link below which shows some patch but there seems no documentation on how / where to apply it , any idea how to apply this patch?

https://bugzilla.redhat.com/show_bug.cgi?id=671204

0

have you tried to mount without any options? From provided link suggestion is to mount with default options : curlftpfs ftp://userid:password@ip-address /home/temp

Also, umask=0000 is too open. Try use 0022 or 0002. Try check /var/log/messages or /var/log/syslog or /var/log/kern.log for some info. "dmesg" command may be helpful too. This depends on distro you are using.

Could you please connect via native ftp-client and upload some files into remote server? May be userid has no write permissions?

0

Just checked the issue was my ftp server was allowing only 1 connection for a user , it seems like for writing it required another connection to be opened increasing limit on ftp server resolved the issue

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.