0

I try to configure sqreen. I installed the pkg,

sqreen-repo:
  cmd.run:
    - name: curl -s {{ sqreenScriptUrl }} | sudo bash
    - unless: test -f /etc/apt/sources.list.d/sqreen_sqreen.list
    - require_in:
      - pkg: sqreen

sqreen:
  pkg.installed:
    - refresh: True
    - pkgs:
      - sqreen-agent
      - sqreen-php-extension
    - reload_modules: true

sqreen-configure:
  cmd.run:
    - name: sqreen-installer config {{ token }}
    - unless: grep {{ token }} /etc/php/7.1/fpm/conf.d/50-sqreen.ini
    - user: root
    - require:
      - pkg: sqreen-agent
    - watch_in:
      - service: php7.1-fpm
      - service: nginx

The pkg is well installed. but when it try to launch sqreen-installer config, it said that:

The following requisites were not found:
    require:
        pkg: sqreen-agent

How it could be so?

$ sudo apt install sqreen-agent
sqreen-agent is already the newest version (1.7.0).
0 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.

If I try to launch manually the sqreen-installer config, it's working well

Thanks for helping!

# EDIT: Found the solution

The require does not match the pkg name, it match the name of the salt action.

In my case, I have:

sqreen:
  pkg.installed:

So the require should be:

- require:
  - pkg: sqreen 
  • Well done :) The watch/require/... statements should work with both names but sometime it does not, and it's hard to find why... – daks Jan 15 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.