1

I've had a prosody running trunk for about a year and haven't had any issues.

I've been testing ejabberd 18.12 and completed a transfer with ejabberdctl import_prosody

on a "migrated" prosody directory with prosody-migrator

Now, carbon copy when messaging others and messaging yourself (bob@domain messaging bob@domain) doesn't seem to work

I'm expecting when I send a message on Conversations, Gajim and Converse.js should also see that sent message. I'm also expecting to see messages I send myself to myself

I've been testing between gajim-nightly, Conversations Beta and converse.js

  • Conversations reports XEP-0280 Message Carbons are available
  • Gajim-nightly enable_message_carbons is activated

Ejabberd while running in foreground doesn't give any information.

In ejabberd, mod_carboncopy: {} should be shown as enabled.

Disabling a account and re-enabling (and triggering MAM) causes these messages to show up. Some tests:

  • bob@domain (Conversations Beta) -> bob@domain:
    • shows up on Gajim but not Converse.js (loads with MAM following account disable / enable)
  • bob@domain (Gajim) -> bob@domain:
    • Neither receive, both (Converse, Conversations) load with MAM following account disable / enable
  • bob@domain (Converse) -> bob@domain:
    • Shows up on Gajim but not Conversations (loads with MAM following account disable / enable)
  • bob@domain (Conversation) -> anotheruser@domain:
    • Message received by anotheruser@domain
    • Neither Conversations nor Converse see it (MAM load with account disable / enable syncs the message for both)
  • bob@domain (Converse) -> anotheruser@domain
    • Message received by anotheruser@domain
    • Neither Conversations nor Gajim see it (MAM load with account disable / enable syncs the message for both)
  • bob@domain (Gajim) -> anotheruser@domain
    • Message received by anotheruser@domain
    • Neither Conversations nor Converse see it (MAM load with account disable / enable syncs the message for both)

tldr; mod_mam is working fine but mod_carboncopy doesn't.

Prosody config

https://paste.debian.net/plainh/0d11e53a

Ejabberd config

https://paste.debian.net/plainh/e90f8952

additional ejabberd config file

https://paste.debian.net/plainh/acddd817

1

This is a bug in 18.12

Apparently should be fixed in 18.12.1

https://github.com/processone/ejabberd/issues/2719

Yes, the regression has been fixed already. Sorry for the inconvenience.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.