I have an issue with correctly setting the SPF record for my own domain. Initially my DNS settings as set by the domainhoster were as follows:

@ TXT "v=spf1 mx ~all"

@ MX 10 mx101.solcon.nl

@ MX 10 mx102.solcon.nl

I tested sending an email and the receiving gmail account gave an SPF soft fail as seen below with the mail ending up in the spam folder.

Received: from mailrelay01.solcon.nl (mailrelay01.solcon.nl [XXXX:XXX:X:XX::XXX]) spf=softfail (google.com: domain of transitioning info@mydomain.com does not designate XXXX:XXX:X:XX::XXX as permitted

I added the IP address that was not designated as permitted to the SPF record.

@ TXT "v=spf1 mx ip6:XXXX:XXX:X:XX::XXX ~all"

However a week later, another one of my mails ended up in gmails spam folder.

Received: from mailrelay04.solcon.nl (mailrelay04.solcon.nl [XXXX:XXX:X:XX::XXX]) spf=softfail (google.com: domain of transitioning info@mydomain.com does not designate XXXX:XXX:X:XX::XXX as permitted

It seems to me that the mailrelay servers are not set as mailservers in my default DNS settings of solcon.nl? Should I add these myself as MX or do I add an include in the SPF record?


  • 2
    You should add to your SPF record exactly what your email provider instructs. – Michael Hampton Dec 13 '18 at 0:59
  • I get the reason for obscuring your email address, but there is no reason to obscure the hosting provider’s name,domain and/or IP addresses. You’ve made it impossible for us to verify anything. – Appleoddity Dec 13 '18 at 2:46
  • 1
    However I got another softfail for the next test mail. The SPF record is in DNS. It gets cached for the TTL. Don't expect it to work immediately, and don't test it by trial and error. Ask your hosting provider what there should be. It's possibly mentioned in their support site or FAQ, too. – Esa Jokinen Dec 13 '18 at 4:32
  • Thank you. I updated my post to clarify that I didnt get a spf softfail again until a week later. I asked the hosting provider for more info with regards to their settings as I couldnt find it on their support site or FAQ. – Freek Dec 13 '18 at 10:45

If your relay provider has an SPF record for their servers, include it as you noted before your policy "~all". Normally, a softfail will not prevent delivery, but it may make it more likely your mail is classified as Spam.

If your relay provider does not have an SPF record, I would seriously consider changing providers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.