0

I have been following this guide in order to configure SSL certificate on XAMPP server where I have enabled SSL on 4433 (as well as 443 after encoutering errors but no result, below config and error is against 443) port. I have created a certificate and kept common name in it as 'mydomain'. This is how my httpd-vhosts.conf file looks like

 #NameVirtualHost mydomain

<VirtualHost mydomain:8888>  
DocumentRoot C:\xampp\htdocs\mydomain  
ServerName mydomain  
    <Directory C:\xampp\htdocs\mydomain>     
                AllowOverride All     
                Allow from All  
    </Directory>

</VirtualHost>
<VirtualHost mydomain:443> 
DocumentRoot C:\xampp\htdocs\mydomain 
ServerName mydomain
<Directory C:\xampp\htdocs\mydomain> 
 AllowOverride All 
 Allow from All 
</Directory> 
 SSLEngine on 
 SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL 
SSLCertificateFile "conf\ssl.crt\mydomain.crt" 
SSLCertificateKeyFile "conf\ssl.key\mydomain.key" 
<FilesMatch "\.(cgi|shtml|pl|asp|php)$"> 
SSLOptions +StdEnvVars 
</FilesMatch>
<Directory "C:\xampp\cgi-bin">
SSLOptions +StdEnvVars
</Directory>
BrowserMatch ".*MSIE.*" nokeepalive ssl-unclean-shutdown downgrade-1.0 force-response-1.0 
</VirtualHost>

I have also made changes in httpd-ssl.conf file accordingly

#General setup for the virtual host
DocumentRoot "C:/xampp/htdocs/mydomain"
ServerName mydomain
ServerAdmin admin@mydomain
ErrorLog "C:/xampp/apache/logs/error.log"
TransferLog "C:/xampp/apache/logs/access.log"

 ....
 SSLCertificateFile "conf/ssl.crt/mydomain.crt"

But no matter what I do, I an unable to get away with this error;

[Thu Dec 13 13:56:25.779456 2018]    [core:notice] [pid 5868:tid 400] AH00094:  Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Thu Dec 13 13:56:25.779456 2018] [mpm_winnt:notice] [pid 5868:tid 400] AH00418: Parent: Created child process 1940
[Thu Dec 13 13:56:26.231857 2018] [ssl:warn] [pid 1940:tid 416] AH01909: mydomain:443:0 server certificate does NOT include an ID which matches the server name
[Thu Dec 13 13:56:26.231857 2018] [ssl:warn] [pid 1940:tid 416] AH01909: mydomain:443:0 server certificate does NOT include an ID which matches the server name
[Thu Dec 13 13:56:26.419057 2018] [ssl:warn] [pid 1940:tid 416] AH01909: mydomain:443:0 server certificate does NOT include an ID which matches the server name
[Thu Dec 13 13:56:26.419057 2018] [ssl:warn] [pid 1940:tid 416] AH01909: mydomain:443:0 server certificate does NOT include an ID which matches the server name

I have Run as Administrator but no progress. My servername and Common name in cerificate are both same. Can someone suggest what else is required to make ssl certificate work on XAMPP.

  • Possible duplicate of serverfault.com/questions/578061/… – garethTheRed Dec 13 '18 at 9:54
  • Thanks @garethTheRed, I recovered from this error, now error.log is not showing any of it but still my TLS handshake gets timeout. – aneela Dec 13 '18 at 10:28
  • Check your firewalls? – garethTheRed Dec 13 '18 at 12:47
  • Yeah I did allow communication on specified ports but still connection gets timedout. There is no error in logs either. – aneela Dec 17 '18 at 5:11
  • Have you set the Listen directive to the correct port? It's not shown above. – garethTheRed Dec 17 '18 at 7:13

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.