I am using Google Cloud Compute Engine running Apache 2.

I enabled HTTP2

sudo a2enmod http2

I added this to the top of my default-ssl.conf and made it global.

Protocols h2 h2c http/1.1

The default-ssl.conf runs properly with all my other commands except protocols.

Then I restarted apache and had zero errors.

sudo systemctl restart apache2

I ran a check and I still get the following:

enter image description here

All my resources are not running HTTP/2. Is there another step that I am missing?

  • Which 11 requests are not served via HTTP/2? Perhaps they are third-party resources from different domains?
    – Tommiie
    Dec 13, 2018 at 10:11
  • They are all from the same domain and one of them is the domain index itself. Dec 13, 2018 at 10:16
  • Can you provide a more complete configuration? What do your logs show?
    – Tommiie
    Dec 13, 2018 at 10:18
  • I just check the error logs. Says: [Thu Dec 13 10:13:20.150740 2018] [http2:warn] [pid 27291] AH10034: The mpm module (prefork.c) is not supported by mod_http2. The mpm determines how things are proc$ Dec 13, 2018 at 10:23
  • 1
    Regarding the MPM warning, check: httpd.apache.org/docs/2.4/howto/http2.html
    – Tommiie
    Dec 13, 2018 at 10:34


You must log in to answer this question.

Browse other questions tagged .