1

I wanted to transfer my mysql databaes from us-east-1 (virginia) to eu-east-1 (ireland) without loosing any data. Also, I want to stop virginia after transfering database from one region to other region.

I have read about read replicas. I have tried once to make one read replica to another region with public access available. Once replica was ready I have promoted it and tried to access publicly . But I was not able to access the database with same credentials .

Also, I have seen blogs related to cloud formation.

  • 1
    "You have tried" is not enough info. Where are the "readers" of the database data located? MLu has the point on security groups. You may think you set them properly but not really. Here is clear explanation on how to create cross region replica. aws.amazon.com/blogs/aws/… – titus Dec 18 '18 at 0:50
2
+25

So the question should really have title Why I can't access RDS Read Replica in a different region? Right?

My assumption is that the Security Group assigned to the Read Replica in eu-east-1 didn't permit access from your location.

Or that you created the read replica in a subnet without IGW (Internet Gateway) and therefore its public IP wasn't accessible.

Make sure you've got the Security Group and Subnet setting correct when creating the RDS Read Replica and you'll be fine.

Hope that helps :)

| improve this answer | |
1

Create a read-replica of your existing RDS instance in another region. Then promote that read-replica to master. Now you have a separate instance running in another region. You can then stop this instance and point your applications

Refer below link

Amazon RDS replica user guide

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.