0

I have problem with mod_proxy65 and ejabberd 16.09-4. Ejabberd crash when I try to use configuration for mod_proxy65. Long ago I used mod_proxy65 with ejabberd 2.x and worked without problem.

When I add this :

host: "proxy.myjabber.org"
name: "File Transfer Proxy"
ip: "IP address" 
port: 7777

ejabbed crash with : no function clause matching lists:map

2018-12-13 17:26:53.711 [error] <0.61.0> CRASH REPORT Process <0.61.0> with 0 neighbours exited with reason: no function clause matching lists:map(#Fun, <<"proxy.myjabber.org">>) line 1238 in application_master:init/4 line 134

When I add host , hostname or ip this breaks config file.

OK, but when I add only :

mod_proxy65: {}

Server is listen on port 7777, accepting connection , but transfer not aways start in both directions /uses IBB/, and the problem is that client trying to use internal IP address which is behind NAT. When I point external address as I said , this will break config file. But with same settings on NAT and ejabberd 2.x file transfer has worked.

Maybe missing something in my configuration?

Thanks in advance

Cheers,

0

I installed ejabberd 16.09 from the binary installer (https://www.process-one.net/en/ejabberd/archive/), and changed the configuration file with those lines:

  mod_proxy65:
    host: "proxy1.example.org"
    name: "File Transfer Proxy"
    ip: "127.0.0.1"
    port: 7778
    max_connections: 5
    access: proxy65_access
    shaper: proxy65_shaper

Then I start ejabberd again, and it starts correctly, no error report. I didn't test the proxy65.

Can you try with another version in your system? You can try to install the binary installer. If it still fails when you put your configuration, please show more details about your configuration file.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.