4

We have two buildings connected by a 30m network cable with a switch on either end. Last week we upgraded some old equipment to support gigabit speeds. One of the two switches was an old 10/100 switch so we upgraded it. Right away the connection between the buildings stopped working.

What we've tried

  1. Plug the old 10/100 switch back in in-between the long run and new gigabit switch. This works, but obviously destroys the upgrade.

  2. The cable was a Cat5e that was installed 4 years ago. It's within the spec, but we thought it might be low quality / damaged, so we ran a brand new Cat7 cable. Same exact behavior as the old Cat5e (ie, it works on the 10/100 switch but not the gigabit switch).

  3. We tried using different gigabit switches on both sides of the cable. Same behavior.

  4. We plugged one end of the cable directly into a gigabit ethernet computer and the other end into the new switch. This worked fine, leading us to suspect there might be an Auto-MDI negotiation problem. We rewired the new Cat7 to be a crossover cable to avoid the need for Auto-MDI. Same behavior.

  5. We connected both of the new switches using a short (2m) patch and cross cables. The connection works perfectly with either one.

What other troubleshooting options do we have at this point?

Equipment details:

  • Old 10/100 switch - TP-Link TL-SF1005D
  • New gigabit switch - TP-Link TL-SG1008D (produced in 2018)
  • Old gigabit switch in building 2 - TP-Link TL-SG1008D (produced in 2016)
  • Replacement gigabit switches we used to test - DLink DGS-1008C and DLink DGS-1008A
  • 2
    Did you try any decent switches ? TP-Link produces garbage. By saying "decent switches" I also mean "managed" - because it's vital to see what's happening on interfaces. So far, by my understanding, you determine link state by only watching the port LED. – drookie Dec 17 '18 at 11:12
  • 2
    Low-cost isn't really "decent". I'd say - get rid of all Compex/TP-Link/D-Link switches, but the problem described above can have nothing with the vendor (but the advice still stands). For the test - get some managed switch, plug the cable just to see what's happening on l2 interface. About your budget and low-cost - buy used cisco on e-bay. – drookie Dec 17 '18 at 12:54
  • 2
    There is no such thing as a gigabit crossover cable. Are you 100% sure the pins-to-pairs mapping on both cables was correct for gigabit ethernet? That's almost always the cause when you have this particular problem. Can you describe in detail how the cable was wired? What is the pin-to-pair mapping? – David Schwartz Dec 17 '18 at 18:31
  • 1
    We need to know the cable is pinned how too, T-568A/B Straight-Through Ethernet Cable ? Did you tried to do a crossover cable ? did you tested the cable after if the 4 pairs are ok ? – yagmoth555 Dec 17 '18 at 18:34
  • 2
    Such a lot of squitter over a squittery $20 switch. – user9517 Dec 17 '18 at 20:43
10

Gigabit requires all 4 pairs, and 10/100 only requires 2 pairs. So "testing" it with the 10/100 switches doesn't really verify that all pairs of the cable are good.

For something like this, you will want to use a cable certifier, not a plain tester that just tests continuity.

30m really isn't that long of a run. If they are newer switches that support low powered Ethernet standards turn off Green Ethernet/EEE/whatever to see if this helps. If for whatever reason they are detecting the run as shorter than it is they might not be pushing enough power on the ports.

Is there any high voltage power running through the same conduit? Power and data should be at minimum 2" apart to avoid EMI (electromagnetic interference).

  • on the EMI front, watch out of office fluorescent lighting tubes, has cause me problems with both long runs of GIG-E (baseband layer 1 ) and ADSL (broadband layer 1) – The Unix Janitor Dec 30 '18 at 12:58
4

It seems likely that the (consumer grade) switch devices are not suitable for the job in hand. You should use better switches - it's the only way to be sure.

3

I think the comment from @DavidSchwartz is the most likely culprit. That is, there really is no such thing as crossover when using gigabit. If you use a cable that has it's tx and rx crossed, it will simply not function when using gigabit. You need to use straight "normal" cables for everything gigabit and beyond (at least in the scope of Base-T).

UPDATE: I've never seen this in practice, but I don't usually go around trying to use crossover cables with gigabit. There is supposed to be a standard for handling this kind of scenario cleanly. From 1000BASE-T onwards the physical medium attachment sublayer (PMA) provides identification of each pair and usually continues to work even over cable where the pairs are unusually swapped or crossed. Beware, a "cheap" switch may not implement this correctly.

Also, watch out for auto-negotiation. Your question indicates that you've performed this upgrade "asymmetrically" -- that is, one of your sites was running a 10/100/1000 switch paired to a 10/100 switch. I would wager that auto-negotiation has been disabled on the "existing" 10/100/1000 switch to make it compatible with the 10/100. Gigabit must auto-negotiate, so be sure that there are no manual speed settings for that port on either 10/100/1000 switch.

  • If it was managed switches, you could force both ports in question to gigabit. – Xalorous Dec 17 '18 at 20:55
  • Hm. They're unmanaged. I didn't actually think about that. You can't force a certain speed on an unmanaged switch, so my suspicion of having done so to force 10/100 is out the window.. However, you should never force a switch to use gigabit. Auto-negotiation is a required part of the gigabit spec. – Spooler Dec 17 '18 at 20:59
  • Well, I'm a lowly sysadmin, our network admins had to configure a connection (connects my lab network to the parent network) to static/forced 1GB connection in order to restore connectivity when the parent organization replaced their switch. – Xalorous Dec 18 '18 at 15:56
0

If it worked for a shorter cable, I'm thinking it might be a signal issue over distance with the new switches. You say you plugged it into a computer using the new switch and it worked, so i'm thinking that those new switches are getting a weaker signal. if you have a multimeter you can test this, or hook the other end back up to the computer and do a throughput test by copying a large file. If the bandwidth is poor it's likely due to the signal being weak and TCP is having to keep asking packets to be resent.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.