0

I accidentally enabled the UFW on my -Google Cloud Platform- Ubuntu instance and unfortunately, port 22 is blocked now. I've tried every way to go inside the VM but I can't. I tried to access through the serial port but it's asking me for user and password that was never set. I also have tried to make new firewall rules to allowing telnet port from my Windows Command prompt but it didn't work. Does anyone have any idea what should I do?

0

Assuming that you are using Compute Engine instance, you could use the startup script to disable ufw on your Ubuntu instance. I found a helpful answer on StackOverflow for you. While trying to connect using serial port, did you follow this article?

If you are using App Engine Flexible, how did you set up UFW? Did you SSH in and configure firewall or used the App Engine Firewall?

In any case you could always create a new VM, this is the philosophy of Cloud Computing that rather spending time on troubleshooting/debugging create a new VM and shutdown the existing one. The other option for you would be to create a private issue on Issue Tracker with your project-id, instance name and other details you feel relevant and wait for the engineers at Google to respond.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.