1

Connect your directories

When we get to the 'Connect your directories' screen in the setup process the forest is auto populated with the correct FDQN of the domain but the 'Add Directory' button is grayed out. We have tried entering the domain manually using the NETBIOS name and the FQDN. We've tried entering other domains. The button never activates. The setup logs show no errors or warnings. We've used Wireshark to try and see what it's trying to do on the network and there is nothing that stands out. We have tried running it on multiple servers and get the same result.

We have poured over the prerequisites and we have run the readiness tools. Again, nothing looks out of the ordinary. At this point we are at a loss.

Has anyone seen this before? Any suggestions on where to proceed next?

  • Are you installing AAD Connect on a Domain Controller? – Hannel Dec 21 '18 at 21:49
1

We think it might be that the documentation is wrong regarding how to install it to a remote database server or that the installer itself has a bug. We followed this: Install Azure AD Connect using SQL delegated administrator permissions

It appears that when you use the flag /useexistingdatabase the installer expects the database to be populated already and doesn't give you the option to connect to a directory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.