1

So, here's the setup - I have a network with a Xen host on it. The Xen host is configured to bridge between the physical network and hosted VMs.

i.e.

[Network] <-----> [Xen DomO / Bridge] <-----> [VM]

This network is partially working, such that:

  • I can ping the VM from my desktop on the network just fine.
  • If I attempt to connect to a port on the VM that's blocked by the firewall, I can see the rejection getting logged on the VM
  • I can access services as normal if connecting from the Xen host

BUT

  • I cannot access any services (SSH or HTTP) directly from my desktop machine. All I see is a connection timeout.

EDIT - Some additional observations from troubleshooting / investigations

  • Despite not being able to SSH in, I seem to have no trouble SSHing out.
  • By using TCPDump to watch the traffic, I can see the TCP handshake failing: the SYN packet travels from desktop -> VM just fine, but the SYN/ACK doesn't appear to be making it all the way back (I can see it leaving the VM and crossing the bridge but it never arrives at my desktop).

What would be causing this, and how would I fix it?

0

Ok, so after a bit of rummaging around I found and fixed two network config issues and everything works now:

  • Routing was incorrectly configured in the guest machine, so it would have been routing its responses to the default gateway.
  • For some reason Fedora Core had created a second config file for the same interface, so NetworkManager was configuring the physical interface with two conflicting configurations (one as a bridge, one as a regular interface with a DHCP address).

After fixing the routing configuration and removing the spurious network config file from /etc/sysconfig/network-scripts it's all behaving itself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.