1

Recently I was doing a Windows 10 upgrade on a machine when a user turned the machine off (at the plug).

They were running a Sandisk 500GB SSD and when rebooted the machine said that there was no boot device.

I expected that the MBR just hadn't been written since Windows was halfway through installation, so tried to re-install but now whatever I do I can't get this SSD to show up anywhere I try it.

I have a SATA caddy which I've used for many other SSDs/disks and never had it fail to talk to one so I tried plugging into that - the caddy has a blue light which comes on when you plug it in and then blinks a few times as it reads the disk.

With the Sandisk SSD the blue light comes on for about 30 seconds then just disappears. The BIOS on the host machine recognises the disk as a Sandisk SSD, I just can't seem to get Windows to understand that the disk is a disk.

It doesn't show up in diskpart, disk manager etc.

Scratching my head here - could the SSD have been damaged somehow when it was writing and the power was lost?

I've tried other disk management tools such as MiniTool etc but I don't think the SSD is even being recognised as a viable disk by anything that I plug it into so I'm not sure where to go from here...

  • Yes indeed, the user could have fried the SSD this way. Not very likely but possible. The SSD might also have committed suicide during the Windows upgrade, and that might have led the user to pull the plug. In either case, the user should be educated that "Don't turn off your computer" also means "Don't unplug it either" – Michael Hampton Jan 1 at 15:30
  • @MichaelHampton Makes a good point. You should ask the user if there was a reason that motivated them to pull the plug. – Zhro Jan 1 at 15:31
  • Yeah, strangling said user is out of the question as I did tell them not to touch it during the upgrade. Might be in the market for a new SSD! (they are just not very bright at the best of times) – Charleh Jan 1 at 15:31
  • You're lucky. SSDs are gotten relatively inexpensive as of late. – Zhro Jan 1 at 15:32
  • @MichaelHampton Any experience of SSDs suiciding during a windows 10 upgrade or is that just on a coincidental basis? – Charleh Jan 1 at 15:33
0

SSDs use a complex translation layer called Flash Translation Layer (FTL). The FTL usually stores some specific drive parameters and the LBA/flash mapping information. Sometime an unexpected power loss can corrupt the FTL, making the drive inoperable. It seems you hit this (rare) corner case. Without proper equipment, you can not do anything to salvage the drive; you have to RMA it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.